[isabelle-dev] Repository Trouble

Johannes Hölzl hoelzl at in.tum.de
Tue Dec 11 10:56:42 CET 2012

Am Montag, den 10.12.2012, 15:27 +0100 schrieb Makarius:
> On Tue, 27 Nov 2012, Johannes Hölzl wrote:
> > We had again a problem with the repository. We fixed it by using again
> >
> >  hg verify
> >  hg strip <failing rev according to verify>
> >
> > now it works again (at least on my machine and on the web server)
> >
> > I used Mercurial 2.0.2 (installed with Ubuntu 12.04).
> > I updated now to Mercurial 2.4 and hope that it does not happen again.
> Since Jasmin reported push problems on the other thread, I did some 
> peeking of the physical repository as well.  This reveals the following:
>    -rw-rw-r-- 1 hoelzl isabelle 0 Nov 27 15:15 .hg/bookmarks
> I vaguely remember that when the first breakdown happened this summer (due 
> to a push by Alex Krauss) the very same odd file was left over, with owner 
> krauss.
> Bookmarks are a version of "branches" in Mercurial, but we don't use them 
> in the Isabelle repository.  Do you use them locally for yourself?

No I do not use them at all. The file is also empty on my local
repository. I only use rebase and Mercurial queues but I don't think
this is related. I assume it is created by the new Mercurial version?

 - Johannes

More information about the isabelle-dev mailing list