[isabelle-dev] Isabelle/jEdit: JVM crash

Christian Sternagel c.sternagel at gmail.com
Tue Dec 9 19:45:32 CET 2014

On 12/09/2014 05:40 PM, Makarius wrote:
> On Tue, 9 Dec 2014, Christian Sternagel wrote:
>> Today Isabelle/jEdit grayed out and became irresponsive after
>> switching from one thy file to another (with C+`). So I waited about 1
>> minute and when nothing seemed to change I killed the corresponding
>> process. As a result I obtained the attached log-file. While this
>> grayout effect is not completely new to me (but rather rare) this was
>> the first time that I saw this kind of log-file.
> This is a JVM crash log caused by SIGSEGV.  Which signal number did you
> actually use for the kill?

I do not remember exactly. Either I just clicked on the "close 
application" button of my Isabelle/jEdit and then it crashed. Or maybe 
that didn't work and so I issued C+c (Control + C) in the terminal from 
which I started Isabelle/jEdit.

> It looks like the main AWT thread crashed while trying to load class
> bytecode from jar files -- but this reading is up to interpretation.
> Sometimes such a problem is caused by implicit updates of the Pure.jar
> or jedit.jar files.  I usually do "isabelle jedit -bf" with a fresh start.
>> isabelle components -l
>> Available components:
>>   /home/griff/.isabelle/contrib/jdk-7u72
> That is the default jdk from Admin/components/main e.g. in 8281f83d286f
>>   /home/griff/.isabelle/contrib/jdk-8u20
> That is a separate jdk, maybe a left-over from some test in
> $ISABELLE_HOME_USER/etc/components or elsewhere.  I recommend to disable
> Java 8 for now -- Oracle is far behind in making it really stable; maybe
> they manage next year ...

Right! Thanks for the hint. Now I remember that I tried this version in 
order to get rid of "the offset problem" for C-hover that reoccurred for 
some reason (maybe a jdk "update") I do not remember. See, e.g.,


>> Btw: How can I tell which of the jdk components is actually used?
> For the sake of Isabelle settings, ISABELLE_JDK_HOME is the main entry
> point.  It is used to enforce JAVA_HOME based on it. With several
> components setting that the last one should win: the JVM crash log also
> says 8.0_20-b26.
> Since you are on Fedora 20, you may also try the on-board OpenJDK, by
> setting ISABELLE_JDK_HOME accordingly.  You can explore the result with
> "isabelle java", e.g. "isabelle java -version".

I tried my "local" OpenJDK and it seems to work.

> You can remove that and use option preferences instead, e.g. see
> Isabelle/jEdit plugin properties: Isabelle / General / Miscellaneous
> Tools / Z3 Non Commercial.

Roger that. Out of curiosity, where are such options actually serialized?



More information about the isabelle-dev mailing list